<!DOCTYPE html><html lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-3&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-3&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-3&cb=2', false, [], true, false, true, false);</script><meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="pingback" href="https://www.knowyourmobile.com/xmlrpc.php" /> <script type="text/javascript">document.documentElement.className = 'js';</script> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><script>var et_site_url='https://www.knowyourmobile.com';var et_post_id='126481';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script> <!-- Powered by Social Snap v1.1.8.3 - https://socialsnap.com/ --><meta property="og:type" content="article"><meta property="og:title" content="Best Apple iPhone XS Deals: Compare The UK&#039;s Best Offers"><meta property="og:description" content="The iPhone XS is still a solid phone to purchase even in 2020. Take a look at the amazing deals we have from the UK&#039;s best network providers."><meta property="og:url" content="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/"><meta property="og:site_name" content="Know Your Mobile"><meta property="og:updated_time" content="2020-08-27T12:00:00+01:00"><meta property="og:image" content="https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-banner.jpg"><meta property="og:image:width" content="1898"><meta property="og:image:height" content="484"><meta property="article:published_time" content="2020-08-27T12:00:00+01:00"><meta property="article:modified_time" content="2020-08-27T12:00:00+01:00"><meta property="fb:app_id" content="1923155921341058"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Best Apple iPhone XS Deals: Compare The UK's Best Offers"><meta name="twitter:description" content="The iPhone XS is still a solid phone to purchase even in 2020. Take a look at the amazing deals we have from the UK's best network providers."><meta name="twitter:image:src" content="https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-banner.jpg"> <!-- Powered by Social Snap v1.1.8.3 - https://socialsnap.com/ --><!-- This site is optimized with the Yoast SEO Premium plugin v14.4.1 - https://yoast.com/wordpress/plugins/seo/ --><title>Best Apple iPhone XS Deals: Compare The UK&#039;s Best Offers</title><meta name="description" content="The iPhone XS is still a solid phone to purchase even in 2020. Take a look at the amazing deals we have from the UK&#039;s best network providers." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" /><meta property="og:locale" content="en_GB" /><meta property="og:type" content="article" /><meta property="og:title" content="Best Apple iPhone XS Deals: Compare The UK&#039;s Best Offers" /><meta property="og:description" content="The iPhone XS is still a solid phone to purchase even in 2020. Take a look at the amazing deals we have from the UK&#039;s best network providers." /><meta property="og:url" content="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" /><meta property="og:site_name" content="Know Your Mobile" /><meta property="article:published_time" content="2020-08-27T11:00:00+00:00" /><meta property="og:image" content="https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-banner.jpg" /><meta property="og:image:width" content="1898" /><meta property="og:image:height" content="484" /><meta name="twitter:card" content="summary_large_image" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.knowyourmobile.com/#organization","name":"Know Your Mobile","url":"https://www.knowyourmobile.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.knowyourmobile.com/#logo","inLanguage":"en-GB","url":"https://www.knowyourmobile.com/wp-content/uploads/2019/04/KYM-logo.png","width":353,"height":128,"caption":"Know Your Mobile"},"image":{"@id":"https://www.knowyourmobile.com/#logo"}},{"@type":"WebSite","@id":"https://www.knowyourmobile.com/#website","url":"https://www.knowyourmobile.com/","name":"Know Your Mobile","description":"The #1 Phone Blog on The Web \u2013 News, Reviews, Advice &amp; Tech Tips","publisher":{"@id":"https://www.knowyourmobile.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.knowyourmobile.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/#primaryimage","inLanguage":"en-GB","url":"https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-banner.jpg","width":1898,"height":484,"caption":"iphone xs banner"},{"@type":"WebPage","@id":"https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/#webpage","url":"https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/","name":"Best Apple iPhone XS Deals: Compare The UK's Best Offers","isPartOf":{"@id":"https://www.knowyourmobile.com/#website"},"primaryImageOfPage":{"@id":"https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/#primaryimage"},"datePublished":"2020-08-27T11:00:00+00:00","dateModified":"2020-08-27T11:00:00+00:00","description":"The iPhone XS is still a solid phone to purchase even in 2020. Take a look at the amazing deals we have from the UK's best network providers.","inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/"]}]},{"@type":"NewsArticle","@id":"https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/#article","isPartOf":{"@id":"https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/#webpage"},"author":{"@id":"https://www.knowyourmobile.com/#/schema/person/bd565236c0ed114f6ba4fb8f84b6cbf5"},"headline":"Best iPhone XS Deals: Compare The UK\u2019s #1 Contract Deals","datePublished":"2020-08-27T11:00:00+00:00","dateModified":"2020-08-27T11:00:00+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/#webpage"},"publisher":{"@id":"https://www.knowyourmobile.com/#organization"},"image":{"@id":"https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/#primaryimage"},"articleSection":"Deals","inLanguage":"en-GB","copyrightYear":"2020","copyrightHolder":{"@id":"https://www.knowyourmobile.com#organization"}},{"@type":["Person"],"@id":"https://www.knowyourmobile.com/#/schema/person/bd565236c0ed114f6ba4fb8f84b6cbf5","name":"Rochelle Royal"}]}</script> <!-- / Yoast SEO Premium plugin. --><!-- knowyourmobile.com is managing ads with Advanced Ads --><script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script> <meta content="Divi Child v.1.0.0" name="generator"/><style type="text/css" media="all">@font-face{font-family:'Noto Serif';font-style:italic;font-weight:400;src:local('Noto Serif Italic'),local('NotoSerif-Italic'),url(https://fonts.gstatic.com/s/notoserif/v8/ga6Kaw1J5X9T9RW6j9bNfFImajC9.woff) format('woff')}@font-face{font-family:'Noto Serif';font-style:italic;font-weight:700;src:local('Noto Serif Bold Italic'),local('NotoSerif-BoldItalic'),url(https://fonts.gstatic.com/s/notoserif/v8/ga6Vaw1J5X9T9RW6j9bNfFIu0RWuc-VK.woff) format('woff')}@font-face{font-family:'Noto Serif';font-display:block;font-style:normal;font-weight:400;src:local('Noto Serif'),local('NotoSerif'),url(https://fonts.gstatic.com/s/notoserif/v8/ga6Iaw1J5X9T9RW6j9bNfFcWbg.woff) format('woff')}@font-face{font-family:'Noto Serif';font-display:block;font-style:normal;font-weight:700;src:local('Noto Serif Bold'),local('NotoSerif-Bold'),url(https://fonts.gstatic.com/s/notoserif/v8/ga6Law1J5X9T9RW6j9bNdOwzfReedw.woff) format('woff')}</style><link rel='stylesheet' id='fvm-header-0-css'  href='https://www.knowyourmobile.com/wp-content/uploads/cache/fvm/1597773063/out/header-9789bfcdff390838b1e2c019dc8daae2af60442e.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var objectL10n = {"reviews":"View Ratings and Reviews"};
var ALPvars = {"page_id":"126481","IsAdminSide":"0","AlpNoAPI":"yesapi","EventTrackingEnabled":"1"};
/*  */</script> <script type='text/javascript' src='https://www.knowyourmobile.com/wp-content/uploads/cache/fvm/1597773063/out/header-ea7409db6598738d0696fb44c573901c9579c43b.min.js'></script><link rel='https://api.w.org/' href='https://www.knowyourmobile.com/wp-json/' /><link rel="alternate" type="application/json+oembed" href="https://www.knowyourmobile.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.knowyourmobile.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&#038;format=xml" /> <script type="text/javascript">jQuery(document).ready( function($) {    
                  if ($('#adsforwp-hidden-block').length == 0 ) {
                       $.getScript("https://www.knowyourmobile.com/front.js");
                  }
              });</script> <style type="text/css" class="amalinkspro-table-css"></style><script type="text/javascript">var ajaxurl = "https://www.knowyourmobile.com/wp-admin/admin-ajax.php";</script><script>var amalinkspro_plugin_url = "https://www.knowyourmobile.com/wp-content/plugins";</script><style type="text/css"></style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" /><meta name="onesignal" content="wordpress-plugin"/> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.knowyourmobile.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '1b8abeec-43a6-4871-96c1-f706cebdf0a2';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.knowyourmobile.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['displayPredicate'] = function() {
              return OneSignal.isPushNotificationsEnabled()
                      .then(function(isPushEnabled) {
                          return !isPushEnabled;
                      });
            };
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <!-- Global site tag (gtag.js) - Google Analytics --> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-2007095-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2007095-1');</script> <!-- Hotjar Tracking Code for https://www.knowyourmobile.com/ --> <script>(function(h,o,t,j,a,r){
        h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
        h._hjSettings={hjid:1464681,hjsv:6};
        a=o.getElementsByTagName('head')[0];
        r=o.createElement('script');r.async=1;
        r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
        a.appendChild(r);
    })(window,document,'https://static.hotjar.com/c/hotjar-','.js?sv=');</script> <script>var clicky_site_ids = clicky_site_ids || []; clicky_site_ids.push(101268303);</script> <script async src="//static.getclicky.com/js"></script> <script>(function(w,d,t,r,u){var f,n,i;w[u]=w[u]||[],f=function(){var o={ti:"26078420"};o.q=w[u],w[u]=new UET(o),w[u].push("pageLoad")},n=d.createElement(t),n.src=r,n.async=1,n.onload=n.onreadystatechange=function(){var s=this.readyState;s&&s!=="loaded"&&s!=="complete"||(f(),n.onload=n.onreadystatechange=null)},i=d.getElementsByTagName(t)[0],i.parentNode.insertBefore(n,i)})(window,document,"script","//bat.bing.com/bat.js","uetq");</script> <script type="text/javascript">window._mNHandle = window._mNHandle || {};
    window._mNHandle.queue = window._mNHandle.queue || [];
    medianet_versionId = "3121199";</script> <meta name="ahrefs-site-verification" content="c1a6bec85c62a0b2e790b4f792dcf9012396cd929bf7fe9b198d8a1e0b8ac560"> <script type="text/javascript">window._mNHandle = window._mNHandle || {};
    window._mNHandle.queue = window._mNHandle.queue || [];
    medianet_versionId = "3121199";</script> <script type='text/javascript'>var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text / javascript';
      var useSSL = 'https: ' == document.location.protocol;
      gads.src = (useSSL ? 'https : ': 'http: ') + 
      '//www.googletagservices.com/tag/js/gpt.js'; 
      var node = document.getElementsByTagName('script')[0]; 
      node.parentNode.insertBefore(gads, node); })();</script><link rel="icon" href="https://www.knowyourmobile.com/wp-content/uploads/2019/04/cropped-favicon-logo-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.knowyourmobile.com/wp-content/uploads/2019/04/cropped-favicon-logo-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.knowyourmobile.com/wp-content/uploads/2019/04/cropped-favicon-logo-180x180.png" /><meta name="msapplication-TileImage" content="https://www.knowyourmobile.com/wp-content/uploads/2019/04/cropped-favicon-logo-270x270.png" /><link rel="stylesheet" id="et-divi-customizer-global-cached-inline-styles" href="https://www.knowyourmobile.com/wp-content/cache/et/global/et-divi-customizer-global-15977542806435.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" />
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158780683-17";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-158780683-17']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'knowyourmobile.com']);
_gaq.push(['f._setDomainName', 'knowyourmobile.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_noads',3]);
_gaq.push(['e._setCustomVar',2,'t','120',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_noads',3]);
_gaq.push(['f._setCustomVar',2,'domain','knowyourmobile.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 176477;
var ezdomain = 'knowyourmobile.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":176477,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"301d6475-e1ce-4bc7-51db-a964ed5d8601","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":339,"serverid":"3.236.39.216:20676","state":"VA","t_epoch":1598621358,"template_id":120,"time_on_site_visit":0,"url":"https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/","user_id":0,"word_count":1068,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-3&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_176477=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["301d6475-e1ce-4bc7-51db-a964ed5d8601", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body class="post-template-default single single-post postid-126481 single-format-standard et_pb_button_helper_class et_non_fixed_nav et_show_nav et_cover_background et_secondary_nav_enabled et_secondary_nav_only_menu et_pb_gutter windows et_pb_gutters3 et_primary_nav_dropdown_animation_fade et_secondary_nav_dropdown_animation_fade et_pb_footer_columns4 et_header_style_left et_right_sidebar et_divi_theme et-db">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KC9Q2TN"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<!-- Google Tag Manager (noscript) --> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KC9Q2TN"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <!-- End Google Tag Manager (noscript) --><div id="page-container"><style>#main-header{ position: relative; top: 0; padding-top: 0px; } .kym_tablet_menu{ display: none; } @media screen and (min-width: 768px){ .kym_menu_mobile{ display: none; } .kym_tablet_menu{ display: flex; justify-content: space-between; align-items: center; padding: 0.5rem; } .kym_tablet_menu--logo{ max-width: 150px; } .kym_tablet_menu--nav ul{ display: flex; } .kym_tablet_menu--nav li{ margin: 1rem; font-weight: bold; } .kym_tablet_menu--nav li a{ color: #333; } .kym_tablet_menu--nav li a:hover{ text-decoration: none; } .kym_tablet_menu--search{ max-width: 100px; } #demo-2 input.et_pb_s{ position: relative; } #top-header-1{ background: #4a4a4a; } .kym_secondary_menu{ padding: 0.6rem; } .kym_secondary_menu #et-secondary-nav{ margin-bottom: 0; display: flex; justify-content: space-between; } .kym_secondary_menu ul li{ font-size: 0.9em; } .kym_secondary_menu ul li a{ color: #fff; } .kym_secondary_menu ul li a:hover{ text-decoration: none; } ul#top-menu, ul#et-secondary-nav{ display: block; } }</style><header id="header" data-height-onload="66"> <!-- MOBILE MENU --><div class="container clearfix et_menu_container kym_menu_mobile"><form  id="demo-2" role="search" method="get" class="et_pb_searchform two" action="https://www.knowyourmobile.com/"><div> <label class="screen-reader-text" for="s">Search for:</label> <input type="submit" value="Search" class="et_pb_searchsubmit" style=""> <input type="text" value="" name="s" class="et_pb_s" placeholder="Search..." style="padding-right: 65px;"> <input type="hidden" name="et_pb_searchform_submit" value="et_search_proccess"><input type="hidden" name="et_pb_include_posts" value="yes"></div></form> <!-- Tablet search --><div class="logo_container"> <span class="logo_helper"></span> <a href="https://www.knowyourmobile.com/"> <img src="https://www.knowyourmobile.com/wp-content/uploads/2019/04/KYM-logo.png" alt="Know Your Mobile" id="logo" data-height-percentage="54" /> </a></div><div class="secondary-menu"><div id="et-top-navigation" data-height="66" data-fixed-height="40"> <nav id="top-menu-nav"><ul id="top-menu" class="nav"><li id="menu-item-243" class="home menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-243"><a href="https://www.knowyourmobile.com/">Home</a></li><li id="menu-item-121173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121173"><a href="https://www.knowyourmobile.com/category/news/">News</a></li><li id="menu-item-121175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121175"><a href="https://www.knowyourmobile.com/category/phones/">Phones</a></li><li id="menu-item-121174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121174"><a href="https://www.knowyourmobile.com/category/user-guides/">User Guides</a></li><li id="menu-item-121176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121176"><a href="https://www.knowyourmobile.com/category/reviews/">Reviews</a></li><li id="menu-item-124150" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-124150"><a href="https://www.knowyourmobile.com/category/deals/">Deals</a></li></ul> </nav><div id="et_mobile_nav_menu"><div class="mobile_nav closed"> <span class="select_page">Select Page</span> <span class="mobile_menu_bar mobile_menu_bar_toggle"></span></div></div><!--<div class="top-button"></div> --></div><div class="primary-top-news mobile"><div class="top-pri-menu"><div class="widget-inner-content"><h2 style="display:none;">Sign up to our newsletter</h2><div class="menu-sign-up-to-our-news-letter-button-container"><ul id="menu-sign-up-to-our-news-letter-button" class="menu"><li id="menu-item-299" class="signup news-letter menu-item menu-item-type-custom menu-item-object-custom menu-item-299"><a href="#">Sign-up to our newsletter</a></li></ul></div></div></div></div><div class="top-right-content desktop"><div class="top-social-icon"><ul class="et-social-icons"><li class="et-social-icon et-social-facebook"> <a href="https://www.facebook.com/KnowYourMobile" class="icon"> <span>Facebook</span> </a></li><li class="et-social-icon et-social-twitter"> <a href="https://twitter.com/KnowYourMobile" class="icon"> <span>Twitter</span> </a></li><li class="et-social-icon et-social-google-plus"> <a href="#" class="icon"> <span>Google</span> </a></li><li class="et-social-icon et-social-instagram"> <a href="#" class="icon"> <span>Instagram</span> </a></li><li class="et-social-icon et-social-rss"> <a href="https://www.youtube.com/user/Knowyourmobile" class="icon"> <span>RSS</span> </a></li></ul></div><div class="top-form"><form role="search" method="get" class="et_pb_searchform" action="https://www.knowyourmobile.com/"><div> <label class="screen-reader-text" for="s">Search for:</label> <input type="text" value="" name="s" class="et_pb_s" placeholder="Search..." style="padding-right: 65px;"> <input type="hidden" name="et_pb_searchform_submit" value="et_search_proccess"> <input type="hidden" name="et_pb_include_posts" value="yes"> <input type="submit" value="Search" class="et_pb_searchsubmit" style=""></div></form></div></div> <!-- #et-top-navigation --></div> <!---- column-secondary-menu ----></div> <!-- .container --><div class="et_search_outer"><div class="container et_search_form_container"><form role="search" method="get" class="et-search-form" action="https://www.knowyourmobile.com/"> <input type="search" class="et-search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:" /></form> <span class="et_close_search_field"></span></div></div> <!-- END MOBILE MENU --> <!-- TABLET MENU --><div class="kym_tablet_menu"><div class="kym_tablet_menu--logo"> <a href="https://www.knowyourmobile.com/"> <img src="https://www.knowyourmobile.com/wp-content/uploads/2019/04/KYM-logo.png" alt="Know Your Mobile" data-height-percentage="54" /> </a></div> <!-- .kym_tablet_menu--logo --><div class="kym_tablet_menu--nav"> <nav><ul id="menu-primary-menu" class="nav"><li class="home menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-243"><a href="https://www.knowyourmobile.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121173"><a href="https://www.knowyourmobile.com/category/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121175"><a href="https://www.knowyourmobile.com/category/phones/">Phones</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121174"><a href="https://www.knowyourmobile.com/category/user-guides/">User Guides</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121176"><a href="https://www.knowyourmobile.com/category/reviews/">Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-124150"><a href="https://www.knowyourmobile.com/category/deals/">Deals</a></li></ul> </nav></div><!-- .kym_tablet_menu--nav --><div class="kym_tablet_menu--search"><form  id="demo-2" role="search" method="get" class="et_pb_searchform two" action="https://www.knowyourmobile.com/"><div> <label class="screen-reader-text" for="s">Search for:</label> <input type="submit" value="Search" class="et_pb_searchsubmit" style=""> <input type="text" value="" name="s" class="et_pb_s" placeholder="Search..." style="padding-right: 65px;"> <input type="hidden" name="et_pb_searchform_submit" value="et_search_proccess"><input type="hidden" name="et_pb_include_posts" value="yes"></div></form> <!-- Tablet search --></div> <!-- .kym_tablet_menu--search --></div> <!-- END TABLET MENU --> </header> <!-- #main-header --><!-- SECONDARY NAV --><div id="top-header-1"><div class="container clearfix"><div class="kym_secondary_menu"><ul id="et-secondary-nav" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121180"><a href="https://www.knowyourmobile.com/category/accessory-review/">Accessories</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121181"><a href="https://www.knowyourmobile.com/category/applications/">Applications</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121182"><a href="https://www.knowyourmobile.com/category/consoles/">Consoles</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121183"><a href="https://www.knowyourmobile.com/category/tablets/">Tablets</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121185"><a href="https://www.knowyourmobile.com/category/wearable-technology/">Wearables</a></li></ul></div> <!-- .kym_secondary_menu --></div> <!-- .container --></div><!-- #top-header --> <!-- END SECONDARY NAV --><div id="et-main-area"><link
href="https://stackpath.bootstrapcdn.com/bootstrap/4.5.0/css/bootstrap.min.css"
rel="stylesheet"
/><style>body { font-family: "Helvetica", Cambria, Cochin, Georgia, Times, "Times New Roman", serif; } .blog-cover { position: relative; background-image: url(""); background-size: cover; background-position: center; color: #fff; } .blog-cover h1 { font-weight: 900; text-transform: uppercase; line-height: 0.9em; color: #fff; font-size: 1.8em; } .blog-cover h2 { font-size: 1.6em; text-transform: uppercase; color: #fff; } .blog-cover .author { font-style: italic; text-transform: uppercase; position: relative; z-index: 1; } .blog-cover .author a{ color: #fff; } .blog-cover .author a:hover{ color: #fff; text-decoration: underline; } .blog-cover:before { content: ""; position: absolute; background: #333; height: 100%; width: 100%; top: 0; left: 0; opacity: 0.8; } .blog-cover:after { content: ""; position: absolute; background: #fff; height: 60%; width: 100%; bottom: 0; left: 0; clip-path: polygon(100% 74%, 0 100%, 100% 100%); z-index: 1; } .blog-cover--inner { display: flex; align-items: center; min-height: 300px; position: relative; z-index: 1; } @media screen and (min-width: 768px) { .blog-cover--inner { min-height: 450px; } .blog-cover--content { max-width: 50%; /* margin-left: auto; */ } .blog-cover h1 { font-size: 2.6em; } } @media screen and (min-width: 992px) { .blog-cover--inner { min-height: 40vh; } .blog-cover--content { max-width: 60%; } .blog-cover h1 { font-size: 2.6em; } } @media screen and (min-width: 1124px) { /* .blog-cover--inner { min-height: 920px; } */ .blog-cover--content { max-width: 44%; } /*.blog-cover h1 { font-size: 6em; }*/ .blog-cover h2 { font-size: 2em; } .blog-cover .author { font-size: 1.2em; font-weight: 300; } } .main-content { font-size: 1.2em; } .main-content h1, .main-content h2, .main-content h3, .main-content h4, .main-content h5, .main-content h6 { font-weight: 600; margin-bottom: 1rem; } .main-content p { margin-bottom: 4rem; } .single #main-content .container{ max-width: 1140px; } .blog-cover-social .et-social-icons{ margin-top: 0.6rem; float: none; }</style><div id="main-content"><div id="post-126481" class="container-fluid blog-cover  et_section_regular" style="background: url(https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-banner.jpg) no-repeat; background-size:cover;"><div class="container"><div class="row"><div class="col-12"><div class="blog-cover--inner"><div class="blog-cover--content"><h1>Best iPhone XS Deals: Compare The UK’s #1 Contract Deals</h1> <!--<h2>A Complete Guide (For Newbies)</h2> --><div class="author"> by <span><a href="https://www.knowyourmobile.com/author/rochelle/" title="Posts by Rochelle Royal" rel="author">Rochelle Royal</a></span> | <span class="the-date">27/08/2020</span> <span class="the-time">12:00 pm</span></div><div> <small><i>This blog post may contain affiliate links</i></small></div><div class="top-social-icon blog-cover-social"><ul class="et-social-icons"><li class="et-social-icon et-social-facebook"> <a href="https://www.facebook.com/KnowYourMobile" class="icon"> <span>Facebook</span> </a></li><li class="et-social-icon et-social-twitter"> <a href="https://twitter.com/KnowYourMobile" class="icon"> <span>Twitter</span> </a></li><li class="et-social-icon et-social-google-plus"> <a href="#" class="icon"> <span>Google</span> </a></li><li class="et-social-icon et-social-instagram"> <a href="#" class="icon"> <span>Instagram</span> </a></li><li class="et-social-icon et-social-rss"> <a href="https://www.youtube.com/user/Knowyourmobile" class="icon"> <span>RSS</span> </a></li></ul></div></div></div></div></div></div></div><!-- end of blog-cover --><div class="container"><div id="content-area" class="row"><div class="col-12"> <!-- /2507246/KYM//knowyourmobile//misc//1 --><div style="text-align: center;"><div id="div-gpt-ad-1557842177324-0"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1557842177324-0'); });</script></div></div> <article id="post-126481" class="et_pb_post post-126481 post type-post status-publish format-standard has-post-thumbnail hentry category-deals"><div class="et_post_meta_wrapper"><p class="post-meta"> by <span class="author vcard"><a href="https://www.knowyourmobile.com/author/rochelle/" title="Posts by Rochelle Royal" rel="author">Rochelle Royal</a></span> | <span class="published">Aug 27, 2020</span> | <a href="https://www.knowyourmobile.com/category/deals/" rel="category tag">Deals</a></p></div> <!-- .et_post_meta_wrapper --><div class="entry-content"><p><b>The iPhone XS is still a solid phone to purchase even in 2020. With the amazing deals we have on offer from the best network providers, you are guaranteed to find a deal for you.</b></p><hr /><h2><b>Unbeatable iPhone XS Deals &amp; Offers</b></h2><div class="topreviews-182" style="display: flex; flex-direction: column; justify-content: center; align-items: center;"><div class="ss-on-media-container"><span class="ss-on-media-image-wrap"><img class="ss-on-media-img" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mP8bwwAAjcBNBRvLA0AAAAASUVORK5CYII=" /><div class="ss-on-media-wrapper   ss-top-left-on-media ss-small-icons ss-with-spacing ss-circle-icons ss-on-media-always-visible"><ul class="ss-social-icons-container ss-on-media-pinit"><li><div data-ss-ss-link="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&media=data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mP8bwwAAjcBNBRvLA0AAAAASUVORK5CYII&description=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" class="ss-pinterest-color ss-pinit-button ss-ss-on-media-button"> <span class="ss-on-media-content"> <i class="ss ss-pinterest"></i>Save </span></div></li></ul></div> </span></div></div><p><script id="tr-topreviews-182" data-ezscrex="false" data-cfasync="false">!function(e){var t="relative",i=document.createElement("iframe"),r=document.querySelector("."+e.wid),isf=r.querySelector('iframe');if(!isf){r.style.position=t,i.style.cssText="width:100%;",i.width="100%",i.height=e.h,i.allowTransparency="true",i.sameSite="none",i.frameBorder="0",i.id=e.wid,i.scrolling="no",i.src=e.uri,r.appendChild(i);}window.addEventListener("message", adjustHT, false); function adjustHT(m){var d=m.data;if(!Array.isArray(d)&&d[0].indexOf("wcem")==-1){return false}var mid=d[0],h=d[1];document.querySelector('#'+mid).height=h+'px';var tspin=r.querySelector('svg');if(tspin){r.removeChild(tspin)}}}({wid:"topreviews-182",uri:"https://www.topreviews.com/compare-brandwise-widget/?cid=6181&bid=545&spid=know-your-mobile&w=100&h=600&wid=topreviews-182&pref=knowyourmobile1&mod=6258&sort-by=2&up-cost=0&data=4000&ps=7",h:"600"})</script></p><h2><b>Is the iPhone XS Worth Buying in 2020?</b></h2><p><div class="ss-on-media-container aligncenter size-large wp-image-126485"><span class="ss-on-media-image-wrap aligncenter size-large wp-image-126485"><img class="ss-on-media-img aligncenter size-large wp-image-126485" src="https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-XS-unboxed-1024x489.png" alt="iphone XS unboxed" width="1024" height="489" srcset="https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-XS-unboxed-980x468.png 980w, https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-XS-unboxed-480x229.png 480w" sizes="((min-width: 0px) and (max-width: 480px)) 480px, ((min-width: 481px) and (max-width: 980px)) 980px, (min-width: 981px) 1024px, 100vw" /><div class="ss-on-media-wrapper   ss-top-left-on-media ss-small-icons ss-with-spacing ss-circle-icons ss-on-media-always-visible"><ul class="ss-social-icons-container ss-on-media-pinit"><li><div data-ss-ss-link="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&media=https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-XS-unboxed-1024x489.png&description=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" class="ss-pinterest-color ss-pinit-button ss-ss-on-media-button"> <span class="ss-on-media-content"> <i class="ss ss-pinterest"></i>Save </span></div></li></ul></div> </span></div></p><p>The <strong><a href="https://www.knowyourmobile.com/phones/is-the-iphone-xs-actually-worth-buying-in-2020-my-2%c2%a2/">Apple iPhone XS</a></strong> (pronouced 10S, not excess) looks identical to the <strong><a href="https://www.knowyourmobile.com/phones/iphone-x-dimensions/">iPhone X</a></strong> which was released back in 2017. Looking at it you might not think much has changed but it is what has been changed on the inside that matters.</p><p>You may think the iPhone XS is outdated but you will be surprised that it is still a powerful smartphone. Thanks to the A12 Bionic processor, at time of release the iPhone XS scored an overall speed of 11,420 in the Geekbench test. This beats the iPhone X (10,357) and the <strong><a href="https://www.knowyourmobile.com/reviews/oneplus-6t-review-our-verdict-six-months-on/">OnePlus 6</a></strong> (9,088). For the non-geeks among us &#8211; the iPhone XS opened Fortnite in 20.8 seconds, Pokemon Go in 4.9 seconds and the racing game Asphalt 9 in 6.17 seconds.</p><p>According to consumer reports, with the help of the A12 chip, the iPhone XS delivers a well-improved battery life on its predecessors and puts it on par with the <strong><a href="https://www.knowyourmobile.com/phones/should-you-buy-a-samsung-galaxy-note-9-in-2020-pros-cons/">Samsung Galaxy Note 9</a></strong>.</p><div style="margin: 20px 0; text-align: center;"><!-- /2507246/KYM//knowyourmobile//misc//3 --><div id=div-gpt-ad-1557842345324-0><script>googletag.cmd.push(function() { googletag.display(div-gpt-ad-1557842345324-0); });</script></div></div><p>It is worth nothing that the A12 is no longer Apple’s newest chipset. It has since been bettered by the A13 Bionic which is used in the <strong><a href="https://www.knowyourmobile.com/deals/iphone-11-deals-uk-contract/">iPhone 11 Series</a></strong>. However, the A12 still outmatches most rivals.</p><p>If you like to keep your iPhone for a number of years, you are safe in buying the iPhone XS. Apple doesn’t advertise this information but one of the iPhone XS’ key features is that the device will continue to receive software support for years to come.</p><p>Software support includes major OS upgrades and a constant stream of bug fixes and security patches.</p><p>As a comparison, Apple has announced that the iPhone 6s, 6s Plus (2015) and original iPhone SE (2016) will not receive the <strong><a href="https://www.knowyourmobile.com/news/apple-ios-13-6-1-is-here/">iOS 13.6.1 update in Aug 2020</a></strong> meaning they had a lifespan of 4-5 years.</p><p>For more detailed information on whether the iPhone XS is worth buying still, check out our indepth breakdown: <a href="https://www.knowyourmobile.com/phones/is-the-iphone-xs-actually-worth-buying-in-2020-my-2%C2%A2/"><b>Is The iPhone XS Actually Worth Buying in 2020?</b></a></p><h2><b>iPhone XS Full Specification</b></h2><ul><li><strong>Dimensions: 143.6 x 70.9 x 7.7 mm</strong></li><li><strong>Weight: 177g</strong></li><li><strong>Display: 5.8in Super Retina OLED 1125 x 2436 pixels</strong></li><li><strong>SoC: Apple A12 Bionic</strong></li><li><strong>Memory: 4GB of RAM</strong></li><li><strong>Storage: 64GB, 256GB &amp; 512GB</strong></li><li><strong>Sensors: Face ID, accelerometer, gyro, proximity, compass, barometer</strong></li><li><strong>Camera (Front): 7 MP, f/2.2, 32mm</strong></li><li><strong>Camera (Rear): 12 MP, f/1.8, 26mm (wide), 1/2.55″, 1.4µm, dual pixel PDAF, OIS;</strong></li><li><strong>12 MP, f/2.4, 52mm (telephoto), 1/3.4″, 1.0µm, PDAF, OIS, 2x optical zoom</strong></li><li><strong>iOS: 13.6.1, released August 12, 2020</strong></li><li><strong>Colors: Space Gray, Silver, Gold</strong></li></ul><p>In terms of camera functionality, the iPhone XS has dual 12MP cameras that have bigger and deeper pixels that let in up to 50 per cent more light in to the shot without sacrificing the sharpness of the end photo.</p><p><div class="ss-on-media-container aligncenter size-large wp-image-126486"><span class="ss-on-media-image-wrap aligncenter size-large wp-image-126486"><img class="ss-on-media-img aligncenter size-large wp-image-126486" src="https://www.knowyourmobile.com/wp-content/uploads/2020/08/Iphone-XS-vs-Cinema-Camera-1024x866.jpg" alt="iPhone XS Photo Comparison" width="1024" height="866" srcset="https://www.knowyourmobile.com/wp-content/uploads/2020/08/Iphone-XS-vs-Cinema-Camera-1024x866.jpg 1024w, https://www.knowyourmobile.com/wp-content/uploads/2020/08/Iphone-XS-vs-Cinema-Camera-980x829.jpg 980w, https://www.knowyourmobile.com/wp-content/uploads/2020/08/Iphone-XS-vs-Cinema-Camera-480x406.jpg 480w" sizes="((min-width: 0px) and (max-width: 480px)) 480px, ((min-width: 481px) and (max-width: 980px)) 980px, (min-width: 981px) 1024px, 100vw" /><div class="ss-on-media-wrapper   ss-top-left-on-media ss-small-icons ss-with-spacing ss-circle-icons ss-on-media-always-visible"><ul class="ss-social-icons-container ss-on-media-pinit"><li><div data-ss-ss-link="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&media=https://www.knowyourmobile.com/wp-content/uploads/2020/08/Iphone-XS-vs-Cinema-Camera-1024x866.jpg&description=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" class="ss-pinterest-color ss-pinit-button ss-ss-on-media-button"> <span class="ss-on-media-content"> <i class="ss ss-pinterest"></i>Save </span></div></li></ul></div> </span></div></p><p>It also benefits from a Smart HDR mode which rivals some DSLR cameras. Apple confirmed that this makes for faster sensors, an enhanced ISP and advanced algorithms. You can also use Depth Control, allowing you to tweak the depth of field after you shoot a portrait photo.</p><h2><b>Main Features Of iPhone XS</b></h2><p><iframe src="https://www.youtube.com/embed/9m_K2Yg7wGQ" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p><h2><b>What A Great Display</b></h2><p>One of the best smartphone screens on the market, According to DisplayMate. The 5.8 inch <strong><a href="https://www.knowyourmobile.com/user-guides/which-iphones-have-oled-screens-guide/">OLED screen</a></strong> offers a brighter display with more pixels and greater colour accuracy than any other iphone display before it. It even rivals the newer iPhone 11 display which is only LCD.</p><p><div class="ss-on-media-container aligncenter size-large wp-image-126482"><span class="ss-on-media-image-wrap aligncenter size-large wp-image-126482"><img class="ss-on-media-img aligncenter size-large wp-image-126482" src="https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-display-spec-1024x747.jpg" alt="iphone xs display spec" width="1024" height="747" srcset="https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-display-spec-980x715.jpg 980w, https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-display-spec-480x350.jpg 480w" sizes="((min-width: 0px) and (max-width: 480px)) 480px, ((min-width: 481px) and (max-width: 980px)) 980px, (min-width: 981px) 1024px, 100vw" /><div class="ss-on-media-wrapper   ss-top-left-on-media ss-small-icons ss-with-spacing ss-circle-icons ss-on-media-always-visible"><ul class="ss-social-icons-container ss-on-media-pinit"><li><div data-ss-ss-link="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&media=https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-display-spec-1024x747.jpg&description=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" class="ss-pinterest-color ss-pinit-button ss-ss-on-media-button"> <span class="ss-on-media-content"> <i class="ss ss-pinterest"></i>Save </span></div></li></ul></div> </span></div></p><p>The larger screen offers a perfect viewing experience for those that like to watch TV/movies, plaay games or even get work done. It is a great alternative to carrying around an iPad. The device also provides amazing viewing angles, making it easy for you to carry out tasks while outside.</p><h2><b>Find The Best iPhone XS Deals</b></h2><p>If you shop around you can always find a better deal  but this takes time and patience. Thats why we included a deal generator at the top of this post. Using this helpful tool you can compare deals from all the major networks and suppliers. You can even narrow your search down by amount of data, upfront cost and monthly budget. Let us do the hard work for you, then all you need to do is decide on the colour iPhone XS that best suits you.<div class="ss-on-media-container aligncenter size-large wp-image-126483"><span class="ss-on-media-image-wrap aligncenter size-large wp-image-126483"><img class="ss-on-media-img aligncenter size-large wp-image-126483" src="https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-colours-1024x576.jpg" alt="iphone xs colours" width="1024" height="576" srcset="https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-colours-980x551.jpg 980w, https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-colours-480x270.jpg 480w" sizes="((min-width: 0px) and (max-width: 480px)) 480px, ((min-width: 481px) and (max-width: 980px)) 980px, (min-width: 981px) 1024px, 100vw" /><div class="ss-on-media-wrapper   ss-top-left-on-media ss-small-icons ss-with-spacing ss-circle-icons ss-on-media-always-visible"><ul class="ss-social-icons-container ss-on-media-pinit"><li><div data-ss-ss-link="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&media=https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-colours-1024x576.jpg&description=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" class="ss-pinterest-color ss-pinit-button ss-ss-on-media-button"> <span class="ss-on-media-content"> <i class="ss ss-pinterest"></i>Save </span></div></li></ul></div> </span></div></p><div class="knowy-after-content_2" id="knowy-1031921349"><p><a href="https://www.knowyourmobile.com/deals/iphone-deals-uk/"><img class="aligncenter wp-image-124300 size-full" src="https://www.knowyourmobile.com/wp-content/uploads/2020/08/Red-Simple-Sale-Twitter-Post.png" alt="iPhone Deals" width="1024" height="512" srcset="https://www.knowyourmobile.com/wp-content/uploads/2020/08/Red-Simple-Sale-Twitter-Post.png 1024w, https://www.knowyourmobile.com/wp-content/uploads/2020/08/Red-Simple-Sale-Twitter-Post-980x490.png 980w, https://www.knowyourmobile.com/wp-content/uploads/2020/08/Red-Simple-Sale-Twitter-Post-480x240.png 480w" sizes="((min-width: 0px) and (max-width: 480px)) 480px, ((min-width: 481px) and (max-width: 980px)) 980px, (min-width: 981px) 1024px, 100vw" /></a></p></div><div class="ss-inline-share-wrapper ss-hover-animation-fade ss-with-counter-border ss-inline-total-counter-left ss-center-inline-content ss-small-icons ss-with-spacing ss-slanted-icons"><p class="ss-social-share-label"> <span>Share via:</span></p><div class="ss-inline-share-content"><ul class="ss-social-icons-container"><li class=""> <a href="#" data-ss-ss-link="https://www.facebook.com/sharer.php?t=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&u=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" class="ss-facebook-color" rel="nofollow noopener"  data-ss-ss-network-id="facebook" data-ss-ss-post-id="126481" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss ss-facebook"></i><span class="ss-network-label">Facebook</span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://twitter.com/intent/tweet?text=Best+iPhone+XS+Deals%3A+Compare+The+UK%E2%80%99s+%231+Contract+Deals&url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&via=KnowYourMobile" class="ss-twitter-color" rel="nofollow noopener"  data-ss-ss-network-id="twitter" data-ss-ss-post-id="126481" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss ss-twitter"></i><span class="ss-network-label">Twitter</span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://www.linkedin.com/shareArticle?title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&mini=true" class="ss-linkedin-color" rel="nofollow noopener"  data-ss-ss-network-id="linkedin" data-ss-ss-post-id="126481" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss ss-linkedin"></i><span class="ss-network-label">LinkedIn</span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://mix.com/add?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" class="ss-mix-color" rel="nofollow noopener"  data-ss-ss-network-id="mix" data-ss-ss-post-id="126481" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss ss-mix"></i><span class="ss-network-label">Mix</span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://www.reddit.com/submit?title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" class="ss-reddit-color" rel="nofollow noopener"  data-ss-ss-network-id="reddit" data-ss-ss-post-id="126481" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss ss-reddit"></i><span class="ss-network-label">Reddit</span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://api.whatsapp.com/send?text=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals%20https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" class="ss-whatsapp-color" rel="nofollow noopener"  data-ss-ss-network-id="whatsapp" data-ss-ss-post-id="126481" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss ss-whatsapp"></i><span class="ss-network-label">WhatsApp</span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://share.flipboard.com/bookmarklet/popout?v=2&title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" class="ss-flipboard-color" rel="nofollow noopener"  data-ss-ss-network-id="flipboard" data-ss-ss-post-id="126481" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss ss-flipboard"></i><span class="ss-network-label">Flipboard</span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&media=https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-banner.jpg&description=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" class="ss-pinterest-color" rel="nofollow noopener"  data-ss-ss-network-id="pinterest" data-ss-ss-post-id="126481" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss ss-pinterest"></i><span class="ss-network-label">Pinterest</span> </span></a></li><li> <a href="#" class="ss-share-all ss-shareall-color" rel="nofollow noopener"> <span class="ss-share-network-content"> <i class="ss ss-plus"></i> <span class="ss-reveal-label-wrap"> <span class="ss-network-label">More</span> </span> </span> </a></li></ul></div><!-- END .ss-inline-share-content --></div><!-- END .ss-inline-share-wrapper --> <!-- Single Desktop Taboola --><div id="taboola-below-article-thumbnails"></div> <script type="text/javascript">window._taboola = window._taboola || [];
                                  _taboola.push({
                                    mode: 'alternating-thumbnails-a',
                                    container: 'taboola-below-article-thumbnails',
                                    placement: 'Below Article Thumbnails',
                                    target_type: 'mix'
                                  });</script> </div> <!-- .entry-content --> <!-- .et_post_meta_wrapper --> </article> <!-- .et_pb_post --></div> <!-- #left-area --></div> <!-- #content-area --></div> <!-- .container --></div> <!-- #main --><div class="et_pb_section et_section_regular section-comment"><div class="et_pb_row post-row"><div class="et_pb_text"><h5>Comments</h5></div><div class="et_post_meta_wrapper inner"></div></div></div> <span class="et_pb_scroll_top et-pb-icon"></span><div class="et_pb_section et_pb_section_1 et_section_regular"><div class="et_pb_row et_pb_row_0"><div class="et_pb_column et_pb_column_4_4 et_pb_column_0  et_pb_css_mix_blend_mode_passthrough et-last-child"><div class="et_pb_module et_pb_code et_pb_code_0"><div class="et_pb_code_inner"><!-- /2507246/KYM//knowyourmobile//misc//2 --><div style="text-align: center;"><div id='div-gpt-ad-1557842287930-0'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1557842287930-0'); });</script> </div></div></div></div> <!-- .et_pb_code --></div> <!-- .et_pb_column --></div> <!-- .et_pb_row --></div> <!-- .et_pb_section --> <footer id="main-footer"><div class="container"><div id="footer-widgets" class="clearfix"><div class="footer-widget"><div id="text-2" class="fwidget et_pb_widget widget_text"><div class="textwidget"><h4 class="title linked-title"><a href="http://www.knowyourmobile.com/contact-us/">Contact</a></h4><p><a href="/cdn-cgi/l/email-protection#e48c8188888ba48f8a8b939d8b9196898b868d8881ca878b89"><span class="__cf_email__" data-cfemail="7f171a1313103f1411100806100a0d12101d16131a511c1012">[email&#160;protected]</span></a></p><p>RPGEE Media, Unit 25129, PO Box 6945, London, W1A 6U</p></div></div> <!-- end .fwidget --><div id="text-12" class="fwidget et_pb_widget widget_text"><h4 class="title">Follow us &#8211; for Mobile</h4><div class="textwidget"><ul class="et-social-icons"><li class="et-social-icon et-social-facebook"></li><li class="et-social-icon et-social-twitter"></li><li class="et-social-icon et-social-youtube"></li></ul></div></div> <!-- end .fwidget --></div> <!-- end .footer-widget --><div class="footer-widget"><div id="nav_menu-3" class="fwidget et_pb_widget widget_nav_menu"><h4 class="title">Menu</h4><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-22494" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-22494"><a href="https://www.knowyourmobile.com/">Home</a></li><li id="menu-item-22473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22473"><a href="https://www.knowyourmobile.com/category/news/">News</a></li><li id="menu-item-22474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22474"><a href="https://www.knowyourmobile.com/category/reviews/">Reviews</a></li><li id="menu-item-22478" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22478"><a href="https://www.knowyourmobile.com/category/user-guides/">User Guides</a></li><li id="menu-item-22475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22475"><a href="https://www.knowyourmobile.com/category/wearable-technology/">Wearable Tech</a></li><li id="menu-item-22476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22476"><a href="https://www.knowyourmobile.com/category/applications/">Apps</a></li><li id="menu-item-22513" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22513"><a href="https://www.knowyourmobile.com/contact-us/">Contact Us</a></li></ul></div></div> <!-- end .fwidget --><div id="nav_menu-7" class="fwidget et_pb_widget widget_nav_menu"><h4 class="title">Menu &#8211; For Mobile</h4><div class="menu-footer-menu-for-mobile-container"><ul id="menu-footer-menu-for-mobile" class="menu"><li id="menu-item-751" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-751"><a href="https://www.knowyourmobile.com/about-us/">About Us</a></li><li id="menu-item-1839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1839"><a href="https://www.knowyourmobile.com/terms-and-conditions/">Terms &#038; Conditions</a></li><li id="menu-item-753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-753"><a target="_blank" rel="noopener noreferrer" href="#">Privacy Policy</a></li><li id="menu-item-754" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-754"><a href="http://www.knowyourmobile.com/sitemap.xml">Site Map</a></li></ul></div></div> <!-- end .fwidget --></div> <!-- end .footer-widget --><div class="footer-widget"><div id="text-3" class="fwidget et_pb_widget widget_text"><h4 class="title">Follow us</h4><div class="textwidget"><ul class="et-social-icons"><li class="et-social-icon et-social-facebook"><a class="icon" href="https://www.facebook.com/KnowYourMobile" target="_blank" rel="noopener noreferrer"></a></li><li class="et-social-icon et-social-twitter"><a class="icon" href="https://twitter.com/KnowYourMobile" target="_blank" rel="noopener noreferrer"></a></li><li class="et-social-icon et-social-youtube"><a class="icon" href="https://www.youtube.com/user/Knowyourmobile" target="_blank" rel="noopener noreferrer"></a></li></ul></div></div> <!-- end .fwidget --></div> <!-- end .footer-widget --><div class="footer-widget"><div id="text-4" class="fwidget et_pb_widget widget_text"><h4 class="title">Sign-up to access Premium content</h4><div class="textwidget"><p>By signing up, you agree to Terms &amp; Conditions and Privacy Policy</p></div></div> <!-- end .fwidget --><div id="gform_widget-2" class="fwidget et_pb_widget gform_widget"><link rel='stylesheet' id='gforms_reset_css-css'  href='https://www.knowyourmobile.com/wp-content/plugins/gravityforms/css/formreset.min.css' type='text/css' media='all' /><link rel='stylesheet' id='gforms_formsmain_css-css'  href='https://www.knowyourmobile.com/wp-content/plugins/gravityforms/css/formsmain.min.css' type='text/css' media='all' /><link rel='stylesheet' id='gforms_ready_class_css-css'  href='https://www.knowyourmobile.com/wp-content/plugins/gravityforms/css/readyclass.min.css' type='text/css' media='all' /><link rel='stylesheet' id='gforms_browsers_css-css'  href='https://www.knowyourmobile.com/wp-content/plugins/gravityforms/css/browsers.min.css' type='text/css' media='all' /> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2},"base_url":"https:\/\/www.knowyourmobile.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.knowyourmobile.com\/wp-content\/plugins\/gravityforms\/images\/spinner.gif"};</script></div> <!-- end .fwidget --></div> <!-- end .footer-widget --></div> <!-- #footer-widgets --></div> <!-- .container --><div id="footer-bottom"><div class="container clearfix"><div class="footer-aff"> <a target="_blank" href="https://www.knowyourmobile.com/recommends/kinsta-hosting/">KYM is Powered By Kinsta.com</a><div class="footer-disc"><p>KnowYourMobile, and its parent company, RPGEE Media LIMITED, is a participant of Amazon Services LLC Associates Program, an affiliate program that is designed to help sites generate revenue by linking to products inside Amazon. We also use other, third-party affiliate networks and retailer affiliate networks. We never recommend any product, however, unless we think it is worthy of your time and money. All products and services are rigorously tested and vetted by our expert team of writers. Affiliate marketing allows us to generate fees that support the maintenance of the site and help pay our writers.</p></div></div> <!-- START OF MAIN FOOTER MENU AND COPYRIGHT --><div id="bottom-content"><div class="widget-inner-content"><div class="menu-main-footer-menu-container"><ul id="menu-main-footer-menu" class="menu"><li id="menu-item-22534" class="year-footer menu-item menu-item-type-custom menu-item-object-custom menu-item-22534"><a>© 2019</a></li><li id="menu-item-310" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-310"><a href="https://www.knowyourmobile.com/about-us/">About Us</a></li><li id="menu-item-1840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1840"><a href="https://www.knowyourmobile.com/terms-and-conditions/">Terms &#038; Conditions</a></li><li id="menu-item-22505" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22505"><a href="https://www.knowyourmobile.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-457"><a href="http://www.knowyourmobile.com/sitemap.xml">Site Map</a></li></ul></div></div></div></div> <!-- .container --></div> </footer> <!-- #main-footer --></div> <!-- #et-main-area --></div> <!-- #page-container --> <script type="text/javascript" src="https://s.skimresources.com/js/135324X1598660.skimlinks.js"></script> <!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com --> <script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-account="24431" data-user="33786" async></script> <!-- / https://optinmonster.com --> <script>jQuery(document).ready(function () {
		jQuery('a').on("click", function () {
			text = jQuery(this).attr('href');
			
			if ( text.indexOf("amzn") >= 0) {
				gtag('event', 'click', { 
					event_category: 'Affiliate Click', 
					event_action: 'Inside: Amazon Click', 
					event_label: text
				});
			}
			if ( text.indexOf("recommends") >= 0) {
				gtag('event', 'click', { 
					event_category: 'Affiliate Click', 
					event_action: 'Inside: Recommends Click', 
					event_label: text
				});
			}
			if ( text.indexOf("fave") >= 0) {
				gtag('event', 'click', { 
					event_category: 'Affiliate Click', 
					event_action: 'Inside: Fave Click', 
					event_label: text
				});
			}
			if ( text.indexOf("target") >= 0) {
				gtag('event', 'click', { 
					event_category: 'Affiliate Click', 
					event_action: 'Inside: Target Click', 
					event_label: text
				});
			}
		});
		jQuery('table').delegate('a', 'click', function() {
			table_a = jQuery(this).attr('href');
			
			if ( table_a.indexOf("amzn") >= 0) {
				gtag('event', 'click', { 
					event_category: 'Affiliate Click', 
					event_action: 'Table: Amazon Click', 
					event_label: text
				});
			}
			if ( table_a.indexOf("recommends") >= 0) {
				gtag('event', 'click', { 
					event_category: 'Affiliate Click', 
					event_action: 'Table: Recommends Click', 
					event_label: text
				});
			}
			if ( table_a.indexOf("fave") >= 0) {
				gtag('event', 'click', { 
					event_category: 'Affiliate Click', 
					event_action: 'Table: Fave Click', 
					event_label: text
				});
			}
			if ( table_a.indexOf("target") >= 0) {
				gtag('event', 'click', { 
					event_category: 'Affiliate Click', 
					event_action: 'Table: Target Click', 
					event_label: text
				});
			}
		});
	});</script> <script type="text/javascript"></script> <script>jQuery(document).ready(function($){
    $('.et-social-icon .icon').each(function(){
        $(this).attr('target', 'blank');
    });
});

jQuery(window).scroll(function(){
  var sticky = jQuery('#custom_html-4.widget_text.et_pb_widget'),
      scroll = jQuery(window).scrollTop();

  if (scroll >= 1000) sticky.addClass('fixed');
  else sticky.removeClass('fixed');
});
jQuery(window).scroll(function(){
  var sticky = jQuery('#custom_html-5.widget_text.et_pb_widget'),
      scroll = jQuery(window).scrollTop();

  if (scroll >= 2000) sticky.addClass('fixed');
  else sticky.removeClass('fixed');
});</script> <script type='text/javascript'>/*  */
var adsforwp_obj = {"ajax_url":"https:\/\/www.knowyourmobile.com\/wp-admin\/admin-ajax.php","adsforwp_front_nonce":"03f652a189"};
var adsforwp_browser_obj = [];
var socialsnap_script = {"ajaxurl":"https:\/\/www.knowyourmobile.com\/wp-admin\/admin-ajax.php","on_media_width":"250","on_media_height":"250","nonce":"d07b79241f","post_id":"126481","click_tracking":""};
var thirsty_global_vars = {"home_url":"\/\/www.knowyourmobile.com","ajax_url":"https:\/\/www.knowyourmobile.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"recommends","link_prefixes":{"1":"recommends"},"post_id":"126481","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
var DIVI = {"item_count":"%d Item","items_count":"%d Items"};
var et_pb_custom = {"ajaxurl":"https:\/\/www.knowyourmobile.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.knowyourmobile.com\/wp-content\/themes\/Divi\/images","builder_images_uri":"https:\/\/www.knowyourmobile.com\/wp-content\/themes\/Divi\/includes\/builder\/images","et_frontend_nonce":"f9aca66772","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"46393e5a2a","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"1","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"126481","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/*  */</script> <script type='text/javascript' src='https://www.knowyourmobile.com/wp-content/uploads/cache/fvm/1597773063/out/footer-277933a0582cee2d491e1bd9b7fc0cdf3776a6ed.min.js'></script><script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?' async='async'></script><script type='text/javascript' src='https://www.knowyourmobile.com/wp-content/uploads/cache/fvm/1597773063/out/footer-5335058a18992cfa7cb6ac5bb429ac016a423338.min.js'></script><style id="et-builder-module-design-cached-inline-styles">.et_pb_column_0{z-index:9;position:relative}</style><div id="ss-all-networks-popup" class="ss-popup-overlay" data-nonce="8ef6a6e93c"><div class="ss-popup"><div class="ss-popup-heading"> <span>Share via</span> <a href="#" id="ss-close-share-networks-modal" class="ss-close-modal" rel="nofollow noopener"><i class="ss ss-close"></i></a></div><!-- END .ss-popup-heading --><div class="ss-popup-content"><div class="ss-popup-networks ss-clearfix"><div class="ss-popup-network ss-popup-facebook"> <a href="#" data-ss-ss-link="https://www.facebook.com/sharer.php?t=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&u=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="facebook" class="ss-facebook-color"  data-ss-ss-network-id="facebook" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" data-has-api="true" rel="nofollow noopener"> <i class="ss ss-facebook"></i> <span>Facebook</span> </a></div><div class="ss-popup-network ss-popup-twitter"> <a href="#" data-ss-ss-link="https://twitter.com/intent/tweet?text=Best+iPhone+XS+Deals%3A+Compare+The+UK%E2%80%99s+%231+Contract+Deals&url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&via=KnowYourMobile" data-id="twitter" class="ss-twitter-color"  data-ss-ss-network-id="twitter" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-twitter"></i> <span>Twitter</span> </a></div><div class="ss-popup-network ss-popup-linkedin"> <a href="#" data-ss-ss-link="https://www.linkedin.com/shareArticle?title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&mini=true" data-id="linkedin" class="ss-linkedin-color"  data-ss-ss-network-id="linkedin" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-linkedin"></i> <span>LinkedIn</span> </a></div><div class="ss-popup-network ss-popup-mix"> <a href="#" data-ss-ss-link="https://mix.com/add?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="mix" class="ss-mix-color"  data-ss-ss-network-id="mix" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-mix"></i> <span>Mix</span> </a></div><div class="ss-popup-network ss-popup-pinterest"> <a href="#" data-ss-ss-link="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&media=https://www.knowyourmobile.com/wp-content/uploads/2020/08/iphone-xs-banner.jpg&description=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="pinterest" class="ss-pinterest-color"  data-ss-ss-network-id="pinterest" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" data-has-api="true" rel="nofollow noopener"> <i class="ss ss-pinterest"></i> <span>Pinterest</span> </a></div><div class="ss-popup-network ss-popup-tumblr"> <a href="#" data-ss-ss-link="https://www.tumblr.com/widgets/share/tool?canonicalUrl=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&posttype=link" data-id="tumblr" class="ss-tumblr-color"  data-ss-ss-network-id="tumblr" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" data-has-api="true" rel="nofollow noopener"> <i class="ss ss-tumblr"></i> <span>Tumblr</span> </a></div><div class="ss-popup-network ss-popup-skype"> <a href="#" data-ss-ss-link="https://web.skype.com/share?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="skype" class="ss-skype-color"  data-ss-ss-network-id="skype" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-skype"></i> <span>Skype</span> </a></div><div class="ss-popup-network ss-popup-buffer"> <a href="#" data-ss-ss-link="https://buffer.com/add?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&text=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="buffer" class="ss-buffer-color"  data-ss-ss-network-id="buffer" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" data-has-api="true" rel="nofollow noopener"> <i class="ss ss-buffer"></i> <span>Buffer</span> </a></div><div class="ss-popup-network ss-popup-pocket"> <a href="#" data-ss-ss-link="https://getpocket.com/save?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="pocket" class="ss-pocket-color"  data-ss-ss-network-id="pocket" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-pocket"></i> <span>Pocket</span> </a></div><div class="ss-popup-network ss-popup-vkontakte"> <a href="#" data-ss-ss-link="https://vk.com/share.php?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="vkontakte" class="ss-vkontakte-color"  data-ss-ss-network-id="vkontakte" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" data-has-api="true" rel="nofollow noopener"> <i class="ss ss-vkontakte"></i> <span>VKontakte</span> </a></div><div class="ss-popup-network ss-popup-xing"> <a href="#" data-ss-ss-link="https://www.xing.com/app/user?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&op=share" data-id="xing" class="ss-xing-color"  data-ss-ss-network-id="xing" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-xing"></i> <span>Xing</span> </a></div><div class="ss-popup-network ss-popup-reddit"> <a href="#" data-ss-ss-link="https://www.reddit.com/submit?title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="reddit" class="ss-reddit-color"  data-ss-ss-network-id="reddit" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" data-has-api="true" rel="nofollow noopener"> <i class="ss ss-reddit"></i> <span>Reddit</span> </a></div><div class="ss-popup-network ss-popup-flipboard"> <a href="#" data-ss-ss-link="https://share.flipboard.com/bookmarklet/popout?v=2&title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="flipboard" class="ss-flipboard-color"  data-ss-ss-network-id="flipboard" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-flipboard"></i> <span>Flipboard</span> </a></div><div class="ss-popup-network ss-popup-myspace"> <a href="#" data-ss-ss-link="https://myspace.com/post?u=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="myspace" class="ss-myspace-color"  data-ss-ss-network-id="myspace" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-myspace"></i> <span>MySpace</span> </a></div><div class="ss-popup-network ss-popup-delicious"> <a href="#" data-ss-ss-link="https://del.icio.us/post?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="delicious" class="ss-delicious-color"  data-ss-ss-network-id="delicious" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-delicious"></i> <span>Delicious</span> </a></div><div class="ss-popup-network ss-popup-amazon"> <a href="#" data-ss-ss-link="https://www.amazon.com/gp/wishlist/static-add?u=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&t=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="amazon" class="ss-amazon-color"  data-ss-ss-network-id="amazon" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-amazon"></i> <span>Amazon</span> </a></div><div class="ss-popup-network ss-popup-digg"> <a href="#" data-ss-ss-link="https://digg.com/submit?title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="digg" class="ss-digg-color"  data-ss-ss-network-id="digg" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-digg"></i> <span>Digg</span> </a></div><div class="ss-popup-network ss-popup-evernote"> <a href="#" data-ss-ss-link="https://www.evernote.com/clip.action?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="evernote" class="ss-evernote-color"  data-ss-ss-network-id="evernote" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-evernote"></i> <span>Evernote</span> </a></div><div class="ss-popup-network ss-popup-blogger"> <a href="#" data-ss-ss-link="https://www.blogger.com/blog-this.g?u=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&n=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="blogger" class="ss-blogger-color"  data-ss-ss-network-id="blogger" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-blogger"></i> <span>Blogger</span> </a></div><div class="ss-popup-network ss-popup-livejournal"> <a href="#" data-ss-ss-link="http://www.livejournal.com/update.bml?event=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&subject=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="livejournal" class="ss-livejournal-color"  data-ss-ss-network-id="livejournal" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-livejournal"></i> <span>LiveJournal</span> </a></div><div class="ss-popup-network ss-popup-baidu"> <a href="#" data-ss-ss-link="http://cang.baidu.com/do/add?iu=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&it=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="baidu" class="ss-baidu-color"  data-ss-ss-network-id="baidu" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-baidu"></i> <span>Baidu</span> </a></div><div class="ss-popup-network ss-popup-newsvine"> <a href="#" data-ss-ss-link="https://www.newsvine.com/_tools/seed&save?u=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&h=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="newsvine" class="ss-newsvine-color"  data-ss-ss-network-id="newsvine" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-newsvine"></i> <span>NewsVine</span> </a></div><div class="ss-popup-network ss-popup-yummly"> <a href="#" data-ss-ss-link="https://www.yummly.com/urb/verify?url=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&title=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals&yumtype=button" data-id="yummly" class="ss-yummly-color"  data-ss-ss-network-id="yummly" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-yummly"></i> <span>Yummly</span> </a></div><div class="ss-popup-network ss-popup-yahoo"> <a href="#" data-ss-ss-link="https://compose.mail.yahoo.com/?body=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&subject=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="yahoo" class="ss-yahoo-color"  data-ss-ss-network-id="yahoo" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-yahoo"></i> <span>Yahoo</span> </a></div><div class="ss-popup-network ss-popup-whatsapp"> <a href="#" data-ss-ss-link="https://api.whatsapp.com/send?text=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals%20https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="whatsapp" class="ss-whatsapp-color"  data-ss-ss-network-id="whatsapp" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-whatsapp"></i> <span>WhatsApp</span> </a></div><div class="ss-popup-network ss-popup-viber"> <a href="#" data-ss-ss-link="viber://forward?text=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals%20https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="viber" class="ss-viber-color"  data-ss-ss-network-id="viber" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-viber"></i> <span>Viber</span> </a></div><div class="ss-popup-network ss-popup-sms"> <a href="#" data-ss-ss-link="sms:?&body=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals%20https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="sms" class="ss-sms-color"  data-ss-ss-network-id="sms" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-sms"></i> <span>SMS</span> </a></div><div class="ss-popup-network ss-popup-telegram"> <a href="#" data-ss-ss-link="https://t.me/share/url?url=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals%20https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F" data-id="telegram" class="ss-telegram-color"  data-ss-ss-network-id="telegram" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-telegram"></i> <span>Telegram</span> </a></div><div class="ss-popup-network ss-popup-messenger"> <a href="#" data-ss-ss-link="https://www.facebook.com/dialog/send?display=popup&link=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&app_id=772401629609127&redirect_uri=https://www.knowyourmobile.com/" data-id="messenger" class="ss-messenger-color"  data-ss-ss-network-id="messenger" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-messenger"></i> <span>Facebook Messenger</span> </a></div><div class="ss-popup-network ss-popup-heart"> <a href="#" data-ss-ss-link="#" data-id="heart" class="ss-heart-color"  data-ss-ss-network-id="heart" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="like" rel="nofollow noopener"> <i class="ss ss-heart"></i> <span>Like</span> </a></div><div class="ss-popup-network ss-popup-envelope"> <a href="#" data-ss-ss-link="mailto:?body=https%3A%2F%2Fwww.knowyourmobile.com%2Fdeals%2Fbest-iphone-xs-deals-compare-uk-contract-offers%2F&subject=Best%20iPhone%20XS%20Deals%3A%20Compare%20The%20UK%E2%80%99s%20%231%20Contract%20Deals" data-id="envelope" class="ss-envelope-color"  data-ss-ss-network-id="envelope" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-envelope"></i> <span>Email</span> </a></div><div class="ss-popup-network ss-popup-print"> <a href="#" data-ss-ss-link="#" data-id="print" class="ss-print-color"  data-ss-ss-network-id="print" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-print"></i> <span>Print</span> </a></div><div class="ss-popup-network ss-popup-copy"> <a href="#" data-ss-ss-link="#" data-id="copy" class="ss-copy-color"  data-ss-ss-network-id="copy" data-ss-ss-post-id="126481" data-ss-ss-location="popup" data-ss-ss-permalink="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" data-ss-ss-type="share" rel="nofollow noopener"> <i class="ss ss-copy"></i> <span>Copy Link</span> </a></div></div><!-- END .ss-popup-networks --><div class="ss-powered-by">Powered by <a href="https://socialsnap.com/?utm_source=WordPress&amp;utm_medium=link&amp;utm_campaign=inthewild" target="_blank" rel="nofollow noopener"><i class="ss ss-socialsnap"></i>Social Snap</a></div><!-- END .ss-powered-by --></div><!-- END .ss-popup-content --></div><!-- END .ss-popup --></div><!-- END #ss-all-networks-popup --><div id="ss-copy-popup" class="ss-popup-overlay"><div class="ss-popup"><div class="ss-popup-heading"> <span>Copy link</span> <a href="#" id="ss-close-share-networks-modal" class="ss-close-modal" rel="nofollow noopener"><i class="ss ss-close"></i></a></div><!-- END .ss-popup-heading --><div class="ss-popup-content"><div class="ss-copy-action"> <input type="text" readonly="readonly" value="https://www.knowyourmobile.com/deals/best-iphone-xs-deals-compare-uk-contract-offers/" class="ss-copy-action-field" aria-label="Copy" /> <a href="#" class="ss-button" rel="nofollow noopener">Copy<span class="ss-share-network-tooltip">Copied</span></a> <i class="ss ss-copy"></i></div><!-- END .ss-copy-action --><div class="ss-powered-by">Powered by <a href="https://socialsnap.com/?utm_source=WordPress&amp;utm_medium=link&amp;utm_campaign=inthewild" target="_blank" rel="nofollow noopener"><i class="ss ss-socialsnap"></i>Social Snap</a></div><!-- END .ss-powered-by --></div><!-- END .ss-popup-content --></div><!-- END .ss-popup --></div><!-- END #ss-copy-popup --> <script type="text/javascript">jQuery(document).ready(function($){
		
		var offset = jQuery('.kym-sidebar-ads').offset();
		jQuery(window).scroll(function(e) {
		  if(window.scrollY >= offset.top) { 
		      jQuery('.kym-sidebar-ads').addClass('fixed');
		  }  else {
		      jQuery('.kym-sidebar-ads').removeClass('fixed');
		  }
		});
		
		$('select[name="cat"]').on('change', function (e) {
			e.preventDefault();

		    var optionSelected = $("option:selected", this);
		    $(optionSelected).attr("selected","selected");

		    var valueSelected = this.value;
		  
		    window.location.replace('/?s&cat='+valueSelected);
		});

		$('input[name=device-result]').click(function() {
	        var sideCat = $(this).val();
	        window.location.replace('/?s&cat='+sideCat);
	    });
	    
	    
        window.almEmpty = function(alm){
          var el = alm.listing;
          var msg = '<p class="ajax-empty-message">No results found</p>';
          
          var item = document.createElement('li');
          item.innerHTML = msg;
          el.appendChild(item); 
          
        };

});
	
	
	jQuery(document).ready(function($) {
    	jQuery( ".ct-tab" ).click(function() {
    		$(this).addClass('active');
    		$(".ct-tab").not($(this)).removeClass('active');
    
    		if ($("#whats-new").hasClass("active")) {
    			$("#tab-what-sec").fadeIn("slow");
    		} else {
    			$("#tab-what-sec").fadeOut("slow");
    		}
    
    		if ($("#most-popular").hasClass("active")) {
    			$("#tab-mp-sec").fadeIn("slow");
    		} else {
    			$("#tab-mp-sec").fadeOut("slow");
    		}
    
    		if ($("#latest-deals").hasClass("active")) {
    			$("#tab-ld-sec").fadeIn("slow");
    		} else {
    			$("#tab-ld-sec").fadeOut("slow");
    		}
    	});
    });
    
window.almComplete = function(alm){
jQuery(document).ready(function($) {
    	var tcount = $('#tab-what-sec .alm-reveal article:first-child .ajx-tc').text();
    	$('.ajx-tr').text(tcount);
    });
};</script> <script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=3&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=3&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="knowyourmobile_com",_audins_did=176477;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-3");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.knowyourmobile_com,DomainId.176477" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body></html>